Macromedia
Dreamweaver and Fireworks: Introduction to Webpage Basics

Kristin Trace, Western School Board Technology Coordinator
272 MacEwen Road | Summerside, PE | C1N 2P7
Tel. (902)888-8400 | Fax (902)888-8449
krtrace@edu.pe.ca
# Table of Contents

CREATE A SITE........................................................................................................................... 4

BACKGROUNDER .......................................................................................................................... 4
TASK: CREATE THE SITE ............................................................................................................... 4

FILE MANAGEMENT ..................................................................................................................... 6

TASK: CREATE FOLDERS ............................................................................................................... 7

PURPOSE ..................................................................................................................................... 8

PAGE LAYOUT .............................................................................................................................. 8

USING “INVISIBLE” TABLES ....................................................................................................... 8
USING PERCENTAGE BASED TABLES ......................................................................................... 8
USING A “CONSTRAINED” TABLE .............................................................................................. 9
TASK: CREATE THE TABLE ......................................................................................................... 9

SITE IDENTITY ........................................................................................................................... 10

MASTHEAD ................................................................................................................................. 11
MOST WEB PAGES USE WHAT IS CALLED A MASTHEAD (IMAGE) AT THE TOP OF THEIR WEBPAGE. THE MASTHEAD HELPS TO CREATE THE SITE IDENTITY .............................................. 11
TASK: CREATE A MASTHEAD .................................................................................................... 11
IMAGE PLACEHOLDER .................................................................................................................. 11
ADD TEXT TO YOUR MASTHEAD .............................................................................................. 12
REFINE/CHANGE YOUR IMAGE ................................................................................................. 14

CREATE A NAVIGATION BAR ..................................................................................................... 15

USING THE BUTTON EDITOR ...................................................................................................... 17
USING MULTIPLE BUTTONS ........................................................................................................ 19
ADD TEXT TO BUTTONS ............................................................................................................... 19
SAVING NAVIGATION BARS ....................................................................................................... 19
PREVIEW WEBPAGE .................................................................................................................... 21

PAGE PROPERTIES ..................................................................................................................... 21

INSERT DATE ............................................................................................................................... 22

ENABLE THE NAVIGATION BAR ................................................................................................. 23
CHECK THE NAVIGATION BAR ........................................................................................................ 24

CREATE THE TEMPLATE .............................................................................................................. 25

CREATE AN EDITABLE REGION .................................................................................................. 26
CREATE PAGES FROM THE TEMPLATE .................................................................................... 27

CHANGE THE LOOK OF YOUR SITE ............................................................................................. 28

APPENDICES ..................................................................................................................................... 29

APPENDIX 1: FTP SET UP AND TESTING..................................................................................... 30
APPENDIX 2: SAMPLE CLASS WEBPAGE PLAN ............................................................................ 31

Please do not copy and redistribute. This is a "beta" version of the handout. I will make available on the Western School Board Website a usable version in the near future.
Create a Site

Backgrounder

Dreamweaver keeps track of how all files (images, audio, html files, etc) are related to each other. If you move, delete, or change a file within the Dreamweaver program, it will take care of making changes to the code of any affected pages and warn you about doing so allowing you to have ultimate control.

Here are some concrete examples of how this can be useful:

1. If you go to delete an image file from the file structure because you no longer wish to have it on the page you are currently working on but you forgot that you also used it on another page. Dreamweaver will let you know and give the option to change your mind.

2. You can find “orphaned” files (files which are not linked to anything). A great way to house clean.

3. You can synchronize the site with your local and remote copies so that they are exactly the same with the last saved version of each file. Synchronizing also allows you to remove old files and add new ones.

You CANNOT create a site within a site! In the past many teachers have used Microsoft FrontPage which allowed teachers to create a WEB for the main page and then allow other teachers to create WEBS which could be imported into the main website later. This does not work in Dreamweaver; however, one benefit is that it doesn’t create duplicate copies of every file you create.

Task: Create the Site

To create a Site, go to the Manage Sites option under the Files Panel (all the sites which exist on your machine will be listed first). If the Files Panel is not open, click on the arrow beside the word files.

Click on the New button and choose Site.
The site definition window gives you two options via the tab system at the top: Basic and Advanced. For our purposes, we will use the basic version. Type the name of your website in the window: Class Website and press the Next Button.

No...you do not want to use a server technology.

Although you can edit files directly on your server, it is recommended that you do all your work on your own machine and then upload the new files to your website. You will also be able to preview them before you upload them in order to be sure they are exactly what you want. So choose the first radio box and navigate (click on the folder) to the main folder where you will be storing your entire website (create a folder if need be).

If you are creating your web page at school, you'll want to create a folder on
your G: drive for this purpose so that you can edit it from any computer in the school. If you create it on a C: drive, you run the risk of losing all your work if the computer needs to be re-imaged and you won’t have access to the files unless at that machine.

In our case, we won’t be uploading our pages to a server so select none. If you plan to upload your work to a personal web server, you would need the FTP information for that. An appendix covering how to do this is included at the end of the package.

Notice, as you finish the wizard it informs you that you can change any of these settings later using the Advanced option.

When you close the wizard, the site you have created will display in the files panel. All files, will be listed in the window…currently, there are no files.

At some point in the future, you might create another site or someone else may use the same computer. If the site you are working on is not listed. Simply click on the “down arrow” beside the folder listed in the Files panel and select yours from the list.

File Management

When naming files for web pages it is advisable to use all lower case letters without spaces. This is because the web interprets spaces as %20% and people...
would have to type that in if they wanted to hit your site directly. Also, you should name your files and folders with obvious names. If the page lists homework for the month of January call it januaryhomework.htm.

When considering your file structure, think about the future. If a graphic will be used throughout a web site, (eg. An icon which appears on various pages within your site, a logo, a masthead, etc) store these all in a graphics folder in the root directory of your website.

If you develop a subproject within your website, store all the files in a folder for that project. This way, you can take the entire folder if it becomes obsolete and delete it quickly rather than hunting for all the files which make up that project. A great idea is to create a sub-folder for graphics which are only part of that project as well.

In the WSB site, you can see that there is a main folder for graphics but in the sub-folder called plagiarismandcopyright there is also a graphics folder (as well as other folders containing support for this topic. In the future, as all material is held in this one sub-folder, it can easily be deleted, moved, updated, etc.)

**Task: Create folders**

To create a folder, simply click once on the folder in which you wish to create a new folder. You will start with the SITE folder. **Right click** it once it is “blue” and choose **new folder**. Type in the name of the folder. You should create a graphics folder and another folder within the graphics folder called pngs. .pngs
are the working files in Fireworks and we will look at these later in more detail.

**Purpose**

Before you begin to create your web site you can save yourself a lot of time in the future by planning what is required now. Appendix 2 contains a basic outline of what might be included in a class webpage. It is usually recommended that web pages have a maximum of 8 main links in their navigation. The same navigation should be available on each page, or at least a bread crumb (a linking trail) be left so that individuals can find their way back from where they came.

**Page Layout**

**Using “Invisible” Tables**

If your editor does not open with a blank page, go to **File> New> Create Basic Page**.

When choosing how to design your page, you have a couple of options. The practice is to use tables to contain all visual webpage elements. Depending on your audience, you can choose to have a table which is a percentage of whatever screen the user has, or you can constrain the table by x number of pixels.

**Using Percentage Based Tables**

The largest issue that crops up when you design a webpage making use of a table which is a percentage of the display area is that the text and images contained within that table display differently on each screen which is visited. If the page contains text only, then it’s not usually an issue as the text will wrap and fill the screen.

Here is the same page viewed on a 800 x 600 resolution and a 1024 x 768 resolution. The content does fill the screen, but the area around the graphic changes quite a bit. If you have graphic heavy pages, you will want to avoid percentage based.
Using a “Constrained” Table

Most monitors (and most in the PEI school system) display at 800 x 600; however, many display at greater resolutions. With this in mind, many web designers use a table to reflect this situation. It is nice to make the table 750 pixels wide and center it so that there is a small margin on either side which frames the webpage.

Have you ever seen web pages which are aligned on the side of the screen leaving a lot of “white space” on the right hand side? Isn’t it irritating? Conversely, sometimes you need to scroll left to right to read information.

This is because the designer did not take into account different screen resolutions. Centering the table, makes it display in the middle of the screen (left to right) so if the users resolution is 800 x 600 or more, it is nicely centered.

**TASK: Create the table**

On your new page, insert the table. On the Common Toolbar at the top of the page, there is a table icon. Single click.

The table wizard will appear. We are going to make a **3 row by 2 column** table which is **750 PIXELS** wide (be careful that this is not left on percentage!). To make the table invisible, the border thickness, cell padding and cell spacing all need to be set at zero. Finally, make sure that the table is **top aligned**.

Dreamweaver and Fireworks: Introduction to Webpage Basics
Kristin Trace :: Western School Board Technology Coordinator
Tuesday, August 23, 2005 (beta version)
When you click okay you will see a table which is indicated by a slashed line (we’ll call this type of line “ants”) The ants won’t show up when you view the page in a web browser, this is just a visual cue for you in Dreamweaver.

Take a moment to save your file and give it the name “template”. You should now see it listed in the file panel on the right hand side of the screen.

Finally, we want to make sure that the constrained table is centered on the page (so that it displays on the center of every browser’s screen regardless of screen size). To select the table, the easiest way to do this is to click on the \textless table\textgreater tag at the bottom of the WYSIWIG screen and look at the Properties panel at the bottom of the screen. Click on Align and choose Center.
Masthead

Most web pages use what is called a masthead (image) at the top of their webpage. The masthead helps to create the site identity.

Task: Create a Masthead

In order to control where images and text are placed, the table can be adjusted to accommodate the item. A masthead usually runs the entire length of the top of a web page. In order to hold this, the two cells at the top of the page must be merged into one cell.

Click in the first cell and while holding down the mouse button drag the cursor into the second cell and release.

Look at the Properties Panel and click on the Merge cell button as indicated.

SAVE your file! It’s a great idea to get into the habit of doing this every time you make a change you like.

Image Placeholder

We will now insert an image placeholder for where the graphic will go. Click in the newly merged top cell and then click on Insert> Image Objects> Image Placeholder.

At this point the Image Placeholder wizard will pop up. It prompts you to give it a name. This will be your eventual file name so use only letters and no spaces in the name. Also, name it what it is! That way you will find it easily later. In this case it is the masthead.
The image will be 750 pixels wide (since our table is 750 pixels wide) and give it a height of 100. This can be changed later if you would like it bigger or smaller.

The Alternate Text is what appears when a mouse is hovered over the image (or if the image does not load on the website). In this case you can use proper grammar as it is NOT a file name.

Save your file.

Select the masthead image placeholder by clicking on it once. Take a look at the Properties Panel. Notice that there is now a button called Create which has a Fw logo on it. Click on it once.

![Properties Panel]

It will take a few minutes as Fireworks is started up. When this happens a file with a blank (white) image the size of the masthead will appear.

**Adding Text to Your Masthead**

Many of the image tools in Fireworks are similar to most graphic editors. We will first add text. Look on the tools panel on the left hand side of the screen and click once on the text button in the Vector Images section.

Nothing will happen. What you need to do is click on the image where you would like your text to start, and while holding down the mouse, drag it to where you would like the text to stop. A blue box (with handles) will appear.

![Text Selection]

Notice that the Properties Panel has again changed to reflect which is selected. In this case the text options are available. Take a moment and change your font, font size, alignment and colour. Later you will have time to explore all the possibilities for making changes to your text (effects, anti-alias, kern, etc).
Once you have finished making your initial changes, you can click on DONE beside the Editing from Dreamweaver indicator.

It will prompt you to save the .png file. Navigate to the png folder you created in your web site and save it there. Notice that it gives it the name masthead.png. You can change this if you desire; however, it does describe the function of the graphic. The png is saved for future editing.

It will then prompt you to save the image which will actually be displayed on the webpage. Navigate to your graphics folder and save it there.
Once you have saved it, it will automatically appear in the Dreamweaver editor and the files you created will be listed in the files panel.

Refine/Change Your Image

Any time you would like to make changes to an image you create, simply select it by clicking on it once. Look at the Properties Panel. It will change to reflect what you can do with the image. In this case, it tells you that the source image is in the graphics folder and is called masthead.gif. It also tells you that the Fireworks source is in graphics/pngs/masthead.png.

To edit the image, just click on the Fireworks Button as before.

Because you have already told Dreamweaver where the png file is, it will open that file in Fireworks, but this time when you press done, it will automatically save the .png and the new .gif file and return you to Dreamweaver with the new image inserted automatically.
Create a Navigation Bar

There are many ways in which to create navigation bars, but this workshop will cover how to make them using Fireworks.

In Appendix 2 there is a quickly brainstormed diagram of what might make up a course webpage. We will use the following main “buttons” in our navigation bar: Home (course outline), Units, Calendar, Links, Learning Strategies.

Just as with the masthead, you should create an image placeholder. Name it navigation and give it a size of 150 pixels by 200 pixels.

Once this has been done, select the placeholder by clicking on it once and then pressing the Fireworks Create button in the Properties Panel. If Fireworks is not already running just wait a few seconds for it to turn on.

Using the Vector Rectangle tool, drag a rectangle on to the canvas. This will eventually be your first button. Don’t worry about colour or size at this point.
Ensuring you select the **Pointer Tool**, right click on the rectangle and select **Convert to Symbol**.

Give the symbol the name Button and click on the “button” radio button. Press OK.

When the Symbol Properties panel closes, your rectangle will have a greenish transparent covering with a circular object in the middle of it. There will also be red lines coming from each corner. This is the “Web Layer” which indicates hotspots and slices which can be programmed and assembled with HTML code.

In order to continue working with the button graphic you’ll need to hide these.

In the tools panel, click on the hide hotspots and slices button under the web category. The image will no longer display the web layer. If at any time you want to see the web layer again, press the left hand button.
Using the Button Editor

Fireworks has a built in Button Editor. The button created can be reused making it a very slick and efficient way to create “custom” buttons.

To activate the button editor, ensure you have the pointer tool selected and double click on the rectangle you have changed into a button symbol. The button editor will open. This editor allows you to create a button which displays differently according to the position it is in. The default is “UP”.

Create the look you would like for your buttons when the webpage loads. In this case since the button is “UP”, a shadow has been used on the rectangle to create that view. You could also use different bevel effects to accomplish this.

The TEXT you input here does not matter…you are merely inputting a placeholder. The words button button seem to give a good estimate of space for most words.
Click on the OVER tab at the top of the button editor and click on the Copy Up Graphic. You can then adjust a few elements to make it look slightly different when the user hovers their mouse over the button. In this case, the text has had a white glow added.

Click on the DOWN tab at the top of the button editor and click on Copy Over Graphic. The changes made here include removing the white text glow and the shadow from the rectangle so that the 3D effect is removed.

If you’d like to create another look for Over While Down, follow the same process; however, we will not include this state as it really isn’t seen for more than a split second anyway.

Finally, leave the Active Area as is. It automatically determines the area which will be “hot” for the web layer. Click on done.

The button you have created will show up on the navigation bar you initially created in Fireworks. Notice that there is a blue line around it indicating the active area.
Using Multiple Buttons

To add copies of the same button, select the first one and copy it (CTRL-C) and paste it (CTRL-V). Then hold down the shift button and press the down arrow about 4 times. Repeat the process until you have 5 buttons evenly aligned top to bottom.

To adjust the canvas so that it encompasses only enough space to accommodate the buttons click on Modify> Canvas> Fit Canvas.

Add Text to Buttons

Finally to add the exact text for each button do the following:

1. Select the Button
2. Change the text in the Properties Panel

Originally it was planned that the final button would be learning strategies, but it didn’t fit on the button so an alternative phrase was used instead. Another solution would be to change the length of the button.

Saving Navigation Bars

When you are ready to save this navigation bar, click on the Done (Editing from Dreamweaver) Button at the top of the screen.

Save the .png file with your other .png files in the .png folder.

Secondly, you will be prompted to save the navigation as an htm file. Create a sub-folder in the graphics folder called menu. Before you click save, make sure you also select the option for “Put Images in a Subfolder” (see next page).
When you click save…the navigation bar will appear automatically in the Dreamweaver page you initiated it from.
The buttons will not work at this point, but to save time later, we will make the template page look exactly as we want it before we do this.

**Preview Webpage**

Save your webpage and preview it in Internet Explorer. You can do this the “old fashioned” way by opening Internet Explorer and navigating to it on your hard drive, or you can simply press F12.

**Page Properties**

We are going to make the page background (behind the table) a different colour to add a nice frame to the page. You can set up the basic properties of your entire page by going to Modify>Page Properties.

As you can see, there are several categories you can choose from (Appearance, Links, Headings, Title/Encoding, and Tracing Image). For our purposes, we will change the Page Font via the drop down menu to Verdana, Arial, Helvetica, sans-serif and in size small. You can change the text colour to compliment your web design; however, remember that a darker colour will display nicely on your light background and print out well.

Did you know that FONTS are always drawn from those available on the machine which you are using? Think back to the times you created a document using a funky font on one computer only to have it disappear when viewing that same document on another computer.
For this reason Dreamweaver, has already selected the varieties of fonts which are available on all machines (Mac and PC). One thing to note is that Verdana has been designed to display in digital mediums making it an excellent choice.

For our purposes, we will not make changes to anything other than the text; however, feel free to play with the other elements at your leisure later on.

Notice that when you click apply that the colour "bleeds" through the table. Simply click on the <table> tag at the bottom of the preview screen to select the entire table and then change the background colour in the properties panel to white.

Insert Date

Insert your mouse in the bottom cell, and change the colour (via the properties panel at the bottom of the screen) to a similar colour to the one you used for your masthead. You can do this by choosing the eyedropper tool.

Right-align the cell.
Finally go to Insert>Insert Date and choose the format you would like from the resulting wizard. If you click on “update automatically on save” it will keep the page up to date each time you make changes to it and save it.

Enable the Navigation Bar

Create a blank html page and save it five times as: index, units, calendar, links, study skills. Take the time to type in the page title on the blank page…this will help for testing purposes. Later on we will replace these blank pages using a template.
Select one of the buttons in Dreamweaver and click on the Fireworks Edit button. Your .png file should open in Fireworks. Select each button, and type in the appropriate file name in the Link area of the Properties Panel. You should also give it the appropriate name in the Alt: area. This is the alternate text which will show up if the image doesn’t load or if the student is using a text reader.

When you are finished, click on Done. You will be returned to Dreamweaver.

**Check the Navigation Bar**

Save the template.htm file and preview it in Internet Explorer. (F12) Test the buttons by clicking on them each in turn. This is where typing in the name of the file on the blank pages will come in handy! You can confirm your pages are linked properly.
Create the Template

Now is the time to create a Dreamweaver Template. There are many benefits to creating a template, but the most useful is the way in which you can update all pages based on the template in a matter of seconds!

To create a template, go to Insert> Template Objects> Make Template.

Dreamweaver will automatically determine the site, list current templates (of which there are none!) and allow you to give it a name. Call it main as this will be the main template for your site.

The links will be updated automatically.
You’ll notice that a folder called “Templates” now exists in the files panel and that the file main.dwt (Dreamweaver Template) is included in it. You can now delete from the file panel, template.htm as it no longer is required.

**Create an Editable Region**

An area (or more than one area) needs to be defined where the content can be added to the site.

Click on the white space and click on Insert> Template Objects> Editable Region.

You will be prompted to give the editable region a name. I like to call it “main” as when there are others, it makes sense to call them “side bar”, “bottom”, etc as where they are located.

The template will now contain a blue tab called main, with the word main in it.

Save your file!!!
Create Pages from the Template

Close the template page. We will now finish creating the shell for your website!

Go to File> New. Click on the Template Tab at the top of the wizard, select your website name and your template name. (Note that the "Update page when template changes" box is checked! This will help you update your site quickly. We will do this quickly after.

Just out of interest. If you have a website which has various pages based on templates, they will be listed and if you click on them you will have a quick preview. Eg. WSB website!

When you click on Create, a version of the template will appear. Note that you can only edit in the editable region. Type in Index in that region and save the file.
as index (you will be saving over the temporary index file!) Do the same for each temporary file.

Preview and see that you have an “instant” website!

**Change the Look of Your Site**

So, it’s a year down the road and you don’t like the colours you chose for your site…or your website is so popular and it is growing and you’ve decided to add a new button. You don’t have to go and edit each page to reflect the new look. Just edit the Dreamweaver Template.

Simply double click the “main.dwt” file in the files panel and edit to your heart’s content…just don’t delete the “editable region”.

In my case, I want to make the colour behind the navigation bar match the colours I used above and below. I also want to change my masthead to a .jpg as it will look nicer.

When finished with editing, click on save. You will be asked if it is okay to update the files based on the template. Click on okay.

Preview your website to see the instant changes.
Appendices
Appendix 1: FTP Set Up and Testing

When you select FTP as the method in which you connect to your remote server, the prompts should be filled in as indicated.

Sometimes an FTP address consists of a series of numbers. You do not always require a folder name.

Make sure you test your connection.

If you are working on a school machine, do not save the password as any student will be able to upload, change or delete files on your site.
Appendix 2: Sample Class Webpage Plan

- Class Webpage
  - Course Outline
    - Units
      - Supporting Links
      - School Page
      - Links to Assignments
      - Student Email
      - Teacher Email
      - Links to Homework
      - Quiz Study Guides
  - Calendar
  - Learning Strategies